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Quick Start
This chapter should help you to get started straight after installing the program. Because of this, only 
essential initialization procedures are described here. It is highly recommended that you read the 
"Working with.." chapter of the handbook.

After you have started TommySoftware® CAD/DRAW Professional, its program window appears. This is 
made up of up to four drawing windows (consisting of rulers, drawing area and crosshair), the status 
window (above the drawing window), the Panel (to the left of the drawing window) and the menu bar.

Your first decision should be whether you want to work with a white or black drawing area. The default 
setting is for a white drawing area. If you prefer a black drawing area, choose System>Settings>Load. 
Choose the file BLACK.T2I from the filing dialog and click on OK. When you have done this, the 
drawing area appears in black. The other window elements change automatically to suitable colors. You 
can also change the color of the drawing area according to your own preferences by choosing 
System>Settings>Colors. See also "Working With TommySoftware® CAD/DRAW Professional" in the 
manual.

Next, you should choose System>Settings>Screen... to set the program window according to your 
requirements and personal preferences. Screen Size and the number of drawing windows are particularly 
important. If you cannot read all of the legends in the status area, try reducing the Font Size in pixels.

Finally, you should choose System>Settings>Memory to configure system memory. This is where you 
specify the amount of memory which is made available for TommySoftware® CAD/Draw Professional. 
Of course this will depend on how much RAM your PC has and how much of it can be used by Windows.
The values in the following table assume that all of the PC's RAM is available to Windows.

All values in KB (kilobytes):

RAM Initial Size System Undo/Redo
3072 512 128 3
4096 1536 256 3
8192 4096 512 5
12288 8096 512 5

Save the settings using System>Settings>Save as... under the name TSCADPRO.T2I in your 
TSCADPRO directory. This will save your settings which will be used automatically the next time you 
start the program.

Now you can start working with TommySoftware® CAD/DRAW Professional.
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Data Exchange
Various Converters are supplied with TommySoftware® CAD/DRAW Professional, which make possible 
the import of drawings which are not in TommySoftware® CAD/DRAW Professional's TVG 2.0 Format, 
or make possible the export of TommySoftware® CAD/DRAW Professional drawings in other formats. 
Using these Converters, you can convert individual drawings or whole sub directories of drawings.

In order to load drawings made with earlier versions of the program into TommySoftware® CAD/DRAW 
Professional , they must first be converted using the program TVG_T2G.EXE (Drawing files saved with 
earlier versions of TommySoftware® CAD/DRAW have the ending TVG; TommySoftware® CAD/DRAW
Professional usually have the ending T2G).

If you have TommySoftware® MEGAPAINT® for Windows you can convert this package's MPG format 
files using the program MPG_T2G.EXE.

The converters DXF_T2G.EXE and T2G_DXF.EXE convert files from and to DXF format.

Please read the README.WRI file in the TSCADPRO directory for the latest information on converters.

It is of course possible to exchange information with other Windows programs via the clipboard. 
Edit>Paste pastes the contents of the Clipboard into the current drawing; Edit>Copy copies all the 
currently selected objects from the drawing to the Clipboard.
It is also possible to export a file in PostScript® or HPGL® format by loading the appropriate printer 
driver and printing to a file rather than the actual device.



Status Window
The Status Window shows important information about the status of the program and displays certain 
other information. The Status Window has the following fields:

Command
This field shows the description of the currently selected command. This command remains active 
until a new command is chosen (see Selecting Commands). The same command can be carried out 
repeatedly without reselecting it. If the mouse pointer is in the Panel, this field shows a short 
description of the function of the Icon which it is over. If the mouse pointer is over a Pen Icon, then 
the name of the Pen is also displayed. If the Popup Menu is displayed, this field shows the name of 
the command whose Icon the mouse is over.

Point
This field shows the type of input which the program is waiting for. If, for example, "Enter Starting 
Point" is shown, the program is waiting for the point from which an object is to be drawn to be 
entered. If "Identify Circle" is shown, then the program is waiting for a circle to be identified.

Layer
This field shows the name of the current Layer. This is normally the Layer in which newly drawn 
objects will be placed. By clicking on the Layer name you can carry out Layer-related commands.

Left Mouse Button
Clicking in the field with the left mouse button carries out the command System>Layer, i.e. you 
can change layers.
Right Mouse Button
Clicking in the field with the right mouse button carries out the command System>Define layers;
i.e. you can view and change the Layer definition.

This field can only be chosen when the Long Status Window check box in the 
System>Settings>Screen dialog has been enabled.

x=, y=
These fields show the coordinates of the point above which the cross-hair is located. If the mouse 
pointer is outside the drawing window, nothing is displayed here.

dx=, dy=
These fields show, after the input of a point, the X and Y difference to the crosshair's previous 
position. If this is not possible, or the mouse pointer is outside the drawing window, nothing is 
displayed here.

l=
These fields show, after the input of a point, the distance between the current crosshair position and 
the starting point. If this is not possible, or the mouse pointer is outside the drawing window, nothing 
is displayed here.

[   ]
The current measurement unit is displayed inside the square brackets.

Left Mouse Button
Clicking with the Left Mouse Button in this field brings up a dialog where you can change the 
measurement unit.

ß=



This field shows the angle of the current crosshair position relative to the starting point. If this is not 
possible, or the mouse pointer is outside the drawing window, nothing is displayed here.

[   ]
The current angle measurement unit is displayed in square brackets after the field ß=.

Left Mouse Button
Clicking with the Left Mouse Button in this field brings up a dialog where you can change the 
angle measurement unit.

System
This field displays the name of the Reference System in use by the current drawing window. By 
clicking on the name of the Reference System, you can carry out commands related to the Reference 
System.

Left Mouse Button
Clicking with the Left Mouse Button in this field brings up a dialog where you can change the 
Reference System for the current window.
Right Mouse Button
Clicking with the Right Mouse Button in this field brings up a dialog where you can view and 
change the Reference System definition.

This field can only be chosen when the Long Status Window check box in the 
System>Settings>Screen dialog has been enabled.



Panel
The Panel displays various Icons. These Icons serve as a representation and a means of specifying settings
and carrying out actual commands. An Icon can be either "inactive", "active" or "unusable". The Icons 
change in appearance according to their condition.    If an Icon is "inactive", it appears to stand out. If it is 
active, it changes in color and appears to be pressed in.
If it is "unusable" it appears to stand out like an "inactive" Icon, but the text and graphics are shown in a 
different color.
The status of an Icon can usually be changed by clicking on it with the left mouse button. This also 
changes the setting which the Icon represents.
In many cases, clicking on an Icon with the right mouse button brings up a dialog which can be used to 
alter the settings associated with the Icon. If the mouse pointer is moved over an Icon, the Command field
in the Status Window displays the command associated with the Icon.

The following listing describes all the Icons from left to right and top to bottom.

Catch mode "Global"
By activating this Icon, the catch function is turned on; the last active catch mode is also activated. 
Alternatively, press F6 (see Key Assignments).
The "Catch" Icon will also be activated, if the catch function is off and one of the catch mode Icons is 
activated. If this happens, the only catch mode to be activated will be the one specifically chosen.
If no catch mode is active, the catch function will be turned off and the Icon will be shown as 
"unusable".The catch function can be turned back on by clicking on one of the catch mode Icons.
If the catch function is turned off, the    last active catch modes are remembered and when the catch 
function is reactivated, either by clicking on the catch Icon or by pressing F6, the last active catch 
modes are restored. This allows the catch function to be temporarily turned off and back on without 
having to activate each individual catch mode.
If the catch function is active, four extra lines are displayed on the crosshair. The distance between 
these lines shows the actual catching radius.
The catching radius is measured in screen pixels. The catching radius determines the maximum 
distance which a point can have from the cursor and still be captured. Clicking on one of the catch 
Icons with the right mouse button brings up a dialog box where you can edit the catching radius.
In the same dialog box you can also set or alter the tolerance; this is needed for Identification (see 
Identification and View>Catch radius...).
More than one catch mode can be active at the same time. However, you should be careful only to 
activate sensible combinations. In general, it is best to only activate the catch modes which you 
actually need to use at any one time.
Instead of clicking with the right button on one of the Icons in the Panel, you can alter the catch mode
by choosing one of the options from the View>Catch modes sub-menu. Active catch modes are 
marked with a tick. Usually, it is best to change the catch modes by clicking on the relevant Icon in 
the Panel.
Changing the catch mode via the menus does however allow you to allocate the 
activation/deactivation of an individual catch mode to a shortcut key for even quicker catch mode 
switching (See also Selecting Commands).

Catch mode "Center"
If this catch mode is active, the centers of lines, circles and arcs can be captured. The object to be 
captured must be identified.
The point which is captured is the midpoint of lines, or the center (the point from which the radius is 
measured) of a circle/arc.



Catch mode "Intersection"
If this catch mode is active, the intersections of objects can be captured. This catch mode will be 
applied to all intersections of Lines, Circles and Arcs, but not to Ellipses, Bézier Curves, Splines or 
Zigzag lines.

Catch mode "Quadrant"
If this catch mode is active, quadrant points of Circles and Arcs can be captured. Quadrant points are 
the intersections of a circle with a cross radiating from its center; they are at 0°, 90°, 180° and 270° 
relative to the center of the circle.

Catch mode "Edge"
If this catch mode is active, the edges of objects can be captured. The object whose edge is to be 
captured must be selected.
A perpendicular is drawn from the ID-Point to the edge of the object. The tangent point is then 
captured. Ellipses, Bézier curves, Splines and zig-zag lines are ignored.

Catch mode "corner/end-point"
If this catch mode is active, corner and end points can be captured.
Amongst other things, endpoints of lines, arcs and curves as well as corner points within curves and 
areas will be captured.

Catch mode "Marking"
If this catch mode is active, markings can be captured.

Catch mode "Pivot"
If this catch mode is active, pivots of Bézier curves which are within curves and areas can be 
captured.

Catch mode "Geometry"
If this catch mode is active, intersections of objects within the Geometry can be captured.

Catch mode "Other Point"
If this catch mode is active, all points of types which cannot be captured in the other catch modes can 
be captured.
These include the centers of circles and arcs, which have to be clicked on directly, as well as the 
centers of ellipses and portions of ellipses.

Arc direction "Positive"
If this direction is active, angles are shown positively, that is, counting anticlockwise.
This mode can be switched by pressing F2.

Arc direction "Negative"
If this direction is active, angles are shown negatively, that is, counting clockwise.
This mode can be switched by pressing F2.

Duplicate on/off
If the Duplicate function is on, a copy of the selected object and not the original is manipulated when 
you change an object with "changing" commands from the Transform and Geometry menus. The 
Duplicate function can also be turned on or off by pressing F7.

Geometry on/off
If the Geometry indicator is active, the objects of the Geometry will be displayed.



Clicking on this Icon with the right mouse button brings up a dialog where you can change the 
Geometry settings (see Geometry>Geometry).

Selection mode "Primary"
This turns the Primary selection mode on. All subsequently selected objects will be selected in this 
mode.

Selection mode "Secondary"
This turns the Secondary selection mode on. All subsequently selected objects will be selected in this 
mode.

Display grid on/off
If this is turned on, the Display grid will, if it is practical, be shown.
By clicking on this Icon with the right mouse button, the Display grid settings can be altered.

Position grid on/off
If the Position grid is active it will, if sensible, be used.
By clicking on this Icon with the right mouse button, the Position grid settings can be altered.
Both the Display and Position grids are determined by the current Coordinate System.

Pen Switch
Up to 40 Pens can be defined. Depending on the screen resolution, a different number of Pens can be 
displayed as Icons in the Panel. Clicking on the Pen switch Icon cycles through all the available Pen 
Icons.

Pens 0 to 40
Clicking on one of these Icons with the left mouse button selects it. This is not possible when the Icon
is displayed as "unusable", because the relevant Pen has not been defined. Clicking on a Pen Icon 
with the right mouse button brings up a dialog where you can define the Pen's characteristics.
In the upper corners of each Pen Icon, there are two colored triangles. The left triangle shows the line 
color used by the printer/plotter; the color of the right hand triangle shows the colors used on screen 
(see System>Define pens).



Drawing Window
Up to four Drawing Windows can be active at the same time. The proportions of Drawing Windows are 
always the same. All Drawing Windows show the same drawing.

Each Drawing Window can be allocated to a different Reference System and Zoom Area.    The Reference
System of the Drawing Window which the cursor is over is displayed in the Status Window. This also 
changes the displayed measurement and angle units, and the display of the Position and Display grids in 
the Panel, because they are determined by the Reference System currently in use. (See Reference 
System).

In order to allocate a new Reference System to a drawing window, it must first be made active by clicking
on the ruler which is then highlighted in color.

Next, the command System>Reference system is used to choose a new Reference System which is then 
immediately applied to the active drawing window.

If the status of the Position of Display grid is changed by clicking on the relevant Icon in the panel, this 
alteration will apply to the active window. The same thing applies if the measurement or angle units are 
altered by clicking on the relevant area in the Status Window or if you set a new origin with the command
System>Set origin.

If a new zoom area is defined with the command View>Zoom section, this section is only set in the 
active Drawing Window.

If more than one Drawing Window is displayed, this procedure can be used to display a whole page 
overview in one of the small windows where zoom areas for the other windows can be chosen.
To do this, first make the small window active by clicking on its ruler. Next, choose View>Zoom page to 
transfer these zoom characteristics to the whole page. Finally make the window which will be the usual 
working window active.
A section of a drawing can be chosen using the View>Zoom section command, in a drawing overview 
window. The chosen area will appear in the main drawing window, but the whole drawing will still be 
shown in the drawing overview window.

If you alter the Zoom area with the help of the scroll bars or the arrow keys, or by pressing +, -, × or ÷ (see 
Key Assignments), the alteration applies to the Drawing Window over which the cursor is positioned. If 
the cursor is not in a drawing window, the keyboard command cannot be carried out.

For all other commands, it makes no difference whether they are carried out in an active or inactive 
window. If you wish, you can start drawing a line in one window and finish drawing it in another.

The rulers are always displayed according to the current measurement unit and zoom area. The dashed 
line represents the page border. The position of the scroll buttons within the scroll bars shows the position
of the zoom area relative to the sheet.
The small page symbol in the lower left corner shows the rotation or    of the current Reference Systems 
(see Reference System).



Selecting Commands
There are several ways of selecting commands: via menus, via the Popup Menu, via the keyboard or - if 
available - a graphics tablet.
In addition, clicking on certain areas in the Panel or the Status Window accesses dialog boxes or allows 
settings to be changed.

Popup Menu
The Popup Menu is a window which consists of Icons and fields for changing layers. An Icon is a graphic
symbol which represents a particular command. The Popup menu is activated either by clicking in the 
drawing window with the right mouse button or by pressing F9.

The Popup Menu can only be activated by clicking with the right mouse button if the program is not 
waiting for input. If the program is waiting for input, the first click of the right mouse button cancels the 
function, and the second click with the right mouse button activates the Popup Menu.

If the cursor is moved over one of the Layer fields in the Popup Menu, the Icons belonging to this Layer 
are shown and the frame around the Layer field will move to the new field.
If the cursor is moved over an Icon, the Icon will be displayed in reversed colors. At the same time, the 
command which the Icon represents will be displayed in the Command field of the Status Window.

Clicking the left mouse button while the cursor is over an Icon carries out the command associated with 
that Icon and leaves the Popup Menu.
Clicking the right mouse button or pressing ESC while the Popup Menu is displayed leaves the Popup 
Menu without carrying out a command.

You can customize the Popup Menu. Choose the command Edit>Change popup menu and then choose 
the command which you want to place in the Popup Menu. In the Popup Menu which appears after this, 
click the cursor at the position where you want the command's Icon to be placed. The "new" Icon replaces
the "old" Icon, and the chosen command can now be accessed via the Popup Menu.

The Popup Menu configuration, together with the keyboard configuration, can either be saved or 
reloaded. This makes it possible to save special Popup Menus and/or keyboard layouts for special 
applications. See Edit>Save assignments as. 

Note: When TommySoftware® CAD/DRAW Professional is started, the configurations from the file 
TSCADPRO.T2B are loaded; this file is stored in the same directory as the program file 
TSCADPRO.EXE. To make new configurations the defaults, they should be saved in the file 
TSCADPRO.T2B.

Assigning commands to keys
You can assign commands to the keys A..Z and 1..0 so that a command can be carried out with a keystroke.
Each key can be used for up to three commands (KEY, SHIFT+KEY, CTRL+KEY).
In order to assign a command to a key, choose Edit>Change keyboard assignment, choose the 
command which you wish to assign to that key. and then indicate the key you wish to use in the dialog 
box which appears. By using the check boxes, you can assign the command to the key in its normal state 
or to the SHIFT+Key or CTRL+Key combinations. If the Info-Mode check box is enabled, clicking on a 
letter or number in the dialog displays its current assignment in an information box.

The command Edit>Display keyboard assignments brings up a dialog where you can see the complete 



list of assignments and delete assignments. Some keys are pre-assigned. You can use the Edit>Display 
keyboard assignments command to view these assignments, which you can of course add to or alter.

Keyboard and Popup Menu configurations can be saved or reloaded. This makes it possible to save 
custom Popup Menus and/or keyboard layouts for special applications. See Edit>Save assignments as. 

Note: When TommySoftware® CAD/DRAW Professional is started, the settings from the file 
TSCADPRO.T2B are loaded; this file is stored in the same directory as the program file 
TSCADPRO.EXE. To make new settings the defaults, they should be saved in the file TSCADPRO.T2B.



Key Assignments
Some commands are permanently allocated to the function keys and alphanumeric keys, which means 
that pressing the relevant key carries out a certain command. In addition, you can allocate commands to 
your own preferred keys. See Selecting Commands.

Alphanumeric keys
ALT+BACKSPACE

Undoes last operation (see Edit>Undo).
The number of operations which can be undone depends on the number of undo levels set with 
Systems>Settings>Memory.

CTRL+BACKSPACE
Undoes last Undo.(see Edit>Redo).
The Redo function undoes the last Undo, i.e. operations which have been Undone are carried out after
all.
The number of operations which can be undone depends on the number of undo levels set with 
Systems>Settings>Memory.

CTRL+INS
Copies all selected objects to the Clipboard (see Edit>Copy).

SHIFT+INS
Pastes all objects from the Clipboard into the drawing (see Edit>Paste).

DEL
Deletes all currently selected objects (see Edit>Delete objects>Selection).

SPACEBAR
Redraws the active drawing window.

ESC
Cancels the last point entry: the operation can then be repeated.
The type of point to be entered or the type of object to be selected next is displayed in the Status 
Window's Point field.

SHIFT+ESC
Restarts the current command. This is the same as choosing the command from the menu again.
This is most useful in the case of commands which are dependent on parameters entered in a dialog 
box immediately after choosing the command.
For example after choosing Drawing>Polyeder>Standard.the number of sides which the Polyeder 
should have must be entered.
All new Polyeders will be drawn with this number of sides, until a new number of sides is specified.
This can be done, if you are still drawing polyeders, by pressing CTRL+ESC, which is quicker than 
choosing the command from the menu.

Function Keys:
F1

Starts the Help function (see Help>Information).
SHIFT+F1

Loads an existing drawing (see File>Load drawing).

F2



Changes the Arc direction (see Panel).
SHIFT+F2

Saves the current drawing under the current name (see File>Save).

F3
Turns Display grid on/off (see Panel).

SHIFT+F3
Saves the current drawing under a new name (see File>Save As...).

F4
Turns Position grid on/off (see Panel).

SHIFT+F4
Prints the current drawing on the currently selected output device

F5
Redraws all currently visible Drawing Windows.

SHIFT+F5
Select a new Zoom area in the active window by dragging out a rectangle (see View>Zoom section).

F6
Turns Catch Function on/off (see Panel).

SHIFT+F6
Alters the Zoom level in the current window so that all existing objects are visible (see 
View>Zoom>Overview).

F7
Turns Duplicate Function on/off (see Panel).

SHIFT+F7
Alters the Zoom level in the current window so that the whole page is visible (see 
View>Zoom>Page).

F8
Allows direct entry of the coordinates of points, direct entry of radii, angles and lengths (see Points).

SHIFT+F8
Alters the Zoom level in the current window so that the drawing is viewed at actual size (see 
View>Zoom>Original size).

F9
Calls the Popup Menu (see Selecting Commands).

SHIFT+F9
View and alter Line patterns (see System>Define line patterns).

F10
Activates Menus.

SHIFT+F10
View and alter Pen definitions (see System>Define pens).

F11
Changes the Reference Systems for the active window (see System>Reference system).

SHIFT+F11
View and edit the Coordinate System definition (see System>Define reference system).

F12
Choose another Layer (see System>Layers).

SHIFT+F12
View and edit Layer definitions (see System>Define layers).



Numeric keypad keys
+

Zooms in on the current cursor position. The cursor is moved to the center of the window and the 
zoom factor doubles.

-
Zooms out on the current cursor position. The cursor is moved to the center of the window and the 
zoom factor halves

÷
Undo Zoom
Undoes up to the last 20 changes of zoom level

ARROW KEYS
Moves the zoom area in the relevant direction.

All of these commands apply to the current drawing window. The Undo Zoom feature also applies only to
the current drawing window - undoing a zoom operation in one window does not affect the zoom levels in
the others.



Dialog Boxes
If you leave a dialog box by clicking on Cancel or pressing ESC the changes made in the dialog will not be
carried out.
Otherwise, clicking on a button will either carry out a special function within the dialog or close the 
dialog box carrying out the changes specified. When the dialog box is next called, it will show the 
currently active settings.

Clicking on a color field brings up a dialog box where you can change the color.
Colors can be chosen in three ways. The simplest way is to click on one of the sixteen standard colors (in 
some cases, this is the only available method).
The other methods are to specify a color as an RGB or CMY value or to specify a user-defined color. You 
do this by choosing an entry from a list box. The chosen color, and its RGB/CMY values will be 
displayed.

A color becomes active when you leave the dialog by clicking on OK.

Non-standard (user defined colours) can be saved from the Select color dialog. By clicking on the Apply 
button the defined color will be incorporated in the list.



Program Configuration
This section describes how you can configure the program to your own wishes and requirements.

If you have not already done so, please read the Quick Start section.

The keyboard and Popup Menu configurations are stored in a configuration file with the ending T2B. This
makes it possible to save custom Popup Menus and/or keyboard layouts. See Edit>Save assignments 
as.... 

Note: When TommySoftware® CAD/DRAW Professional is started, it uses the configuration from the file
TSCADPRO.T2B; this file is stored in the same directory as the program file TSCADPRO.EXE. To make
new settings the defaults, they should be saved in the file TSCADPRO.T2B.

All other settings which directly affect the program are stored in a file with the ending T2I. (see 
System>Settings>Load.

Note: When TommySoftware® CAD/DRAW Professional is started, it uses the settings from the file 
TSCADPRO.T2I; this file is stored in the same directory as the program file TSCADPRO.EXE. To make 
new settings the defaults, they should be saved in the file TSCADPRO.T2I.

The following list provides a key to the settings. Refer to it when making changes.
A * shows that a particular setting is very important for the configuration of TommySoftware® 
CAD/DRAW Professional and you should use this setting in your own configuration (*.T2I) file
The descriptions of the individual commands, explain the meaning of each setting in detail.
The other settings have less effect on the fundamental workings of the program but more effect on the 
program's interface. These settings will probably be changed every time the program is used..

The settings controlling the following commands are stored in a settings file (*.T2I).

File>Load drawing
* File>Autosave

File>Print drawing
* View>Display

View>Key functions>Arc direction
View>Key functions>Catch
(see Key Assignments and Panel)
View>Key functions>Duplicate
(see Key Assignments and Panel)
View>Catch Radius (see also Panel)
View>Catch Mode (see also Panel)

* System>Settings>Screen
* System>Settings>Colors
* System>Settings>Memory
* System>Settings>Time format
* System>Settings>Paths
* System>Settings>Autoload

Draw>Freehand drawing Parameters
Draw>Zigzag line Parameters

* Geometry>Geometry (see also Panel)
Geometry>Marking>Layer



Geometry>Division and Geometry>Multiple copy
Measure>Dimension (The settings for each sub-menu are stored separately.)
Measure>Dimension>Line properties
Measure>Dimension>Text properties
Measure>Hatching types>Define
Special>Generate surface>Properties
Special>Generate surface>Parameters

* Special>Font table
Special>Font table>Properties
Special>Single line text and Special>Multiple line text (all settings except the current text)
Library>Insert Symbol/Block
Library>Symbol/Block>Properties
Library>Read Symbol/Block
Library>Generate parts list
Selection>Selection mode (see also Panel)
User defined Colors

The settings which apply to a specific drawing are saved along with the drawing itself in the drawing's 
T2G file. See File>Load drawing... and File>Merge drawing>Standard elements... and File>Merge 
drawing>Other elements....
Loading a drawing from a drawing file automatically loads the settings associated with that drawing.This 
is very useful because settings and definitions are very much dependent on the individual drawing and 
vary widely from drawing to drawing.

Note: When a new drawing is started or TommySoftware® CAD/DRAW Professional is started, the 
settings from the file TSCADPRO.T2G are used; this file is stored in the same directory as the program 
file TSCADPRO.EXE. To make new settings the defaults, they should be saved in the file 
TSCADPRO.T2G.

The following list of commands provides a key to their settings and can be used to alter them. The 
supplied file TSCADPRO.T2G already contains some standard settings, in particular Pen and Line 
definitions conforming to the DIN standards. You should always use this file as a sample when you wish 
to define your own settings. Please read the descriptions of the individual commands, which explain the 
meaning of each setting in detail.
The following settings are saved in the drawing file:

View>Zoom areas
System>Define Layers
System>Define reference systems
System>Page format
System>Define pens
System>Define line patterns

You should exercise extreme caution when altering TSCADPRO.* files. If you do accidentally erase a 
TSCADPRO.* file, you can substitute a corresponding file from the SYSTEM subdirectory of your 
TSCADPRO directory by copying it and renaming it. The files STANDARD.T2G, STANDARD.T2B, 
BLACK.T2I or WHITE.T2I contain the standard settings.

You should never amend these files directly, but always work with a copy.



View/Zoom
A drawing can be shown on the screen at various sizes. The visible part of the drawing, the Zoom area, is 
shown relative to the original size (that is, the size at which the drawing will be printed. See also 
View>Zoom).
This relative size is expressed as the Zoom or Zoom Factor. If the factor is 1.0, the drawing is shown at 
original size, in which case the drawing's elements appear on screen at the same size as that at which they 
will be printed.
You can view part of a drawing at original size by choosing View>Zoom>Original size.
There are several similar commands in the View menu.

By choosing View>Zoom>Section you can select a rectangular section of your drawing, which then 
becomes the active Zoom area. See also Drawing Window.

You can save frequently used Zoom areas with the command View>Zoom area>Define.

The command View>Undo zoom allows you to undo the last 20 zoom actions in each window. See also 
Key Assignments and Drawing Window.

In addition, it is possible to influence the ways in which objects are displayed; see View>Display.



Properties
In order to depict an object, apart from geometric information (e.g. the coordinates of a line's end points), 
certain other data is required which define, for example, the color, line width and line pattern with which 
the object should be drawn. These pieces of information are called characteristics.

An object has the following characteristics:
Number of the assigned layer;
Line style, made up of line pattern, line width and line color;
Fill style, made up of fill mode and fill color;
Number of the assigned pen.

If a Pen other than Pen 0 is assigned to an object, usually the object will be drawn with the Line Style and 
Fill Style assigned to that Pen. Because of this direct relationship with Pens, it is possible, with a single 
alteration of the Pen definition, to alter    the appearance of all objects drawn with that Pen.
If Pen 0 has been used, the characteristics remain with the object. In this case, altering the Pen definition 
will make no difference to the appearance of the object.

Each object is assigned, via a Layer number, to a particular Layer. These layers have an organizational 
purpose. They make it possible to organize individual parts of a drawing and to go quickly to any drawing
element. Outlines, Symmetry and Help lines, hatching, measurements and descriptive text should each be 
assigned to their own Layer.
To speed up screen redraws or make the drawing clearer, the layer containing (for example) hatching can 
be removed.

When an object is drawn, it is normally assigned to the current Layer and Pen. It makes sense to allocate 
specific types of object to specific layers and possibly also to specific Pens, to achieve a consistent 
structure to the drawing. With the help of certain commands, distinct characteristics can be specified for 
these purposes which can be allocated to specific object types. These are:

Geometry>Marking>Layer...
Measure>Dimension>Line properties
Measure>Dimension>Text properties
Measure>Hatch Objects>Properties
Special>Generate Surface>Properties
Special>Font Table>Properties
Library>Insert Symbol/Block>Properties

Theoretically, problems can arise if an object has been allocated to a particular Pen, but must retain some 
of its properties unaltered as they are decisive for that object. In these cases, it is possible to lock some of 
an object's properties against alteration. For example, it can be decided that a particular object will always
be drawn with 0.25 mm line width, regardless of which Pen is selected.
This locking can be carried out with the command Shape>Edit properties>Object. The object which is 
to have properties fixed must be selected, and the properties must be changed in the dialog box which 
appears.
The line width can be altered to the desired value. By doing this, the Transmit check box is automatically 
enabled, which fixes the line width. After closing the dialog box by clicking on OK, the line width of the 
object will be independent of the chosen Pen.

Carrying out a similar process with symbols is slightly more complicated. A symbol may consist of 
several objects. Each of these objects might have totally different properties. If a symbol is instanced (see 
Symbols and Blocks), i.e. if a "copy" of the symbol is on screen, each of the individual objects which 



make up the symbol will be displayed with its properties.
Problem: to make a symbol, regardless of the properties of its individual elements, display completely in 
red. The properties of the individual objects cannot be changed, because there is only one instance of the 
symbol. It must be possible to make all the objects in this instance of the symbol appear in red. This is 
done in a similar way to the fixing of a line's width described above.
To do this, choose the command Shape>Edit properties>Object and identify the relevant instance of the
symbol. A dialog box appears, showing the instance's current properties.
Next, the line color is changed to red. By doing this, the check box Transmit will be enabled, which fixes 
the line color to the objects in the symbol. Close the dialog box by clicking on OK. All objects of this 
instance will be shown with red lines. The objects of the original symbol will not be altered.
It may be that some of the objects of which the symbol consists have a fixed line color. In this case, the 
line color will not be displayed in red, but in the fixed color..



Layers
TommySoftware® CAD/DRAW Professional drawings can have up to 300 separate Layers. Layers are 
used to structure a drawing by putting elements with the same theme on the same Layer. By doing this, 
they can be manipulated in the same way later.

Layers should be used to structure the drawing right from the start. To do this layers can be set in the 
program, and certain important elements will be automatically assigned to these layers. This maintains the
structure automatically.
The following drawing elements can be assigned to their own layers:

Dimensions (see Measure>Dimension>Properties)
Hatching (see Measure>Hatch objects>Properties)
Marks (see Geometry>Marking>Layer)
Generated Surfaces (see Special>Generate surface>Properties)
Text (see Special>Font table>Properties)
Symbols / Blocks (see Library>Insert Symbol/Block>Properties)

All other drawing elements are always placed into the current Layer.

By organizing your work into defined layers, you can make your work a lot easier: individual layers can 
be frozen or removed. It is much easier to maintain a well-ordered drawing.

It is possible to organize a drawing into layers after it has been completed: however this needs so much 
effort that it is not really practical.

See also System>Layers and System>Define layers.



Reference Systems
Reference Systems play a central role in TommySoftware® CAD/DRAW Professional. Reference Systems
(or "Systems") contain all the important settings for screen drawing and working within a window.

A Reference System has these parts:

View
The Display setting influences the display of the drawing in the window. As well as the unmodified 
Cartesian display, various modified display types can be chosen, which make the production of 
isometric and dimetric drawings easier.
For example, if. Isometric, left view is chosen, the on-screen representation of the drawing will be 
altered so that parts of the drawing which belong to the left view are shown unmodified.
The left face of an isometric cube is, in the drawing, a parallelogram with two sides at 90 ,and two 
sides at 150°. Each of the sides is the same length. However, because the top and bottom sides are 
tilted, the parallelogram is smaller horizontally than vertically.
The display of the drawing in the window is modified in such a way that the parallelogram is shown 
as a quadrilateral. The display is sheared vertically by 30°, in order to balance out the vertical angle of
150° and scaled by the factor 1/cos(30°) horizontally, in order to preserve the aspect ratio.
Because all the drawing's elements are modified equally, the other views of the cube appear to be 
more distorted than they actually are.
The distortion of the drawing is visible because of the position of the page frame and the page 
symbol. (See System>Settings>Screen).
See also "Isometric Drawing".

Rotation
The Rotation setting influences the position of the coordinate axes relative to the page. Rotation of    
30° means that the coordinate axes are each rotated by 30°.
Because the coordinate axes on the screen always run horizontally and vertically, the page is rotated 
by 30°, the effect is the same.
The rotation of the drawing is always visible from the position of the page frame and the page symbol
(see System>Settings>Screen).

Scale
The scale influences the input and output of coordinates. Internally, the drawing is always saved at the
same size as that at which, under normal circumstances, it will be printed. This is the same as a scale 
of 1:1.
If the drawing is to be produced at a different size, the program has to be told, so that the coordinates 
and lengths can be recalculated.
A scale of 1:100 means that the internal coordinates must be multiplied by 100 before output, and 
divided by 100 after input.
Because the scale is only indirectly connected with the drawing, altering the scale does not alter the 
drawing itself.
If it is to be output at a different size, either it must be directly scaled during printing or scaled with 
the command Shape>Scale objects.

Origin
This determines the position of the coordinate origin. This is the point around which the Reference 
System is rotated (see Rotation), and distortion is carried out relative to this point (see Display)
The origin can be either set to a defined position on the edge of the sheet, or placed relative to the 
center of the sheet.



Units
These settings determine in which units the input and output of coordinates, lengths, angles and other 
measurements are carried out.
The Length Unit is used for the input and output of coordinates, lengths, radii, clearances, 
dimensions, and all measurements which depend on the drawing scale.
The Line Unit is used for the input and output of line widths, text sizes, and other measurements 
which do not depend on the drawing scale.
Finally, the Angle Unit is used for the input and output of all angle types.

Numbers and Precision
These settings determine how numbers are displayed.
It is particularly important to set the number display correctly. For drawings using feet and inches, it 
is usually necessary to set this to Mixed fraction.

Display Grid and Position Grid
These grids help with the production of drawings which have to be placed on a predetermined grid.
The display grid can be set independently of the position grid.

See also System>Reference systems, System>Define reference systems.



Points
Points can be entered in two different ways: by clicking in the Drawing Window, or by using the 
keyboard.

The type of point to be entered next is shown in the Status Window's Point field.

When using the mouse, the actual position of the cursor in the Drawing Window determines where the 
point will be placed. The positioning of the cursor can be influenced if a position Grid is active; if this is 
the case the cursor can only be moved to certain positions.

Point entry with the keyboard is context sensitive. A dialog box appears after pressing F8 (see Key 
Assignments) which allows you to enter absolute, relative (to the
previous point) or polar co-ordinates depending on the active command (line, circle etc.) and the point 
which is to be entered. According to the type of command, it is possible to choose a point on the sheet or 
on the edge of the currently selected object.

You can remove the last-entered point by pressing ESC.

All entries use the current measurement units, as displayed in the Status Window.

An object, e.g. a line or circle (see the Draw menu) consists of a certain number of points from which it is
calculated. These points can be displayed, appearing as small right angles, by choosing View>Display.



Selection
Selection of an individual object: see Identification.

By Selection, we mean choosing one or more objects. There are various methods of selecting objects; see 
also the Selection menu. Selected objects can be manipulated in various ways, e.g. rotated or scaled.

The selected area is indicated by a frame around the selected objects or by indicating the object's edge 
with a dashed line. You can alter this setting with View>Display, and change the color of the frame/line 
by using System>Settings>Color.

In many cases, objects with the same properties (e.g. line width, object type or Layer allocation) have to 
be selected. This is achieved with the command Selection>Conditional selection which brings up a 
dialog box where you can specify the characteristics of the objects to be selected.

There are two different selection modes: primary and secondary selection. These are displayed in different
colors. The active selection mode is shown in the panel. Normally, primary selection is active; secondary 
selection is mainly used for hatching.

Objects remain selected until explicitly deselected, using Deselection. Deselection has the same options 
as selection. Selection is not preserved when a drawing is saved, i.e. when a drawing is loaded, nothing is 
selected.



Identification
For many commands, objects must be identified. Objects are identified by clicking on their outlines.

The type of object to be identified next is shown in the Status Window's Point field.

The point which is clicked on during identification is referred to as the ID-Point. The current catch radius 
(see Panel) determines how far the ID-Point can be from the object's outline and still be valid. If two 
objects overlap, or are very close together, it is difficult to clearly identify one of the objects. The 
Catching Radius Tolerance shows how accurate one must be to make a valid identification. If the 
tolerance is, for example, 3 pixels, an identification is only regarded as clear if there is no other object 
within a radius of 3 pixels of the chosen object. If this is not the case, you can choose from all objects 
which fall within the area.(See Variants).

There are commands where the position of the ID-point relative to the object is very important. One 
example of this is the command Geometry>Trim line>Intersection with perpendicular. When using 
this command, the line which is to be trimmed must be identified, and then the two perpendiculars to 
which the line is to be trimmed must be identified. The position of the ID-Point determines the part of the 
line which is to be trimmed    the portion of line nearest to the ID-point will be removed.

In general (as far as the ID-Point is concerned), wherever you click, something changes.



Variants
Variants are used, for example, during Identification (see Identification). If an identification is not clear, a 
dialog box appears at the bottom of the screen to choose which object should be identified. If you 
reposition this dialog box, the next time it is used it will appear in the new position.

Using the dialog box, you can choose one of the possibles to be identified. To do this, one of the objects is
shown with a frame and a dashed line round its outline. You can change the color of the frame or the 
outline with Systems>Settings>Colors.

Clicking on OK identifies the currently framed object and closes the dialog. The Forwards and 
Backwards buttons let you cycle forwards or backwards through the possibles. Clicking on Cancel closes 
the dialog without identifying an object.

During the construction of objects, variants are also sometimes required. In this case, the procedure is 
similar to that described here, except that the choice is from objects which can be drawn.



Geometry
The Geometry is an aid to construction. The only objects which can be included in the geometry are lines 
and circles. The lines are shown with infinite elasticity, in principle they are straight.

See also Geometry>Geometry line, Geometry>Geometry parallel, Geometry>Geometry tangent and
Geometry>Geometry circle.

The Geometry can be turned on and off, see Geometry>Geometry and "Panel". The Geometry is saved 
and loaded with the drawing. Additionally, it is possible to load the Geometry from a file into the current 
drawing using the command File>Merge drawing>Other Elements. The Geometry is never printed out 
and cannot be copied to the Clipboard.

Objects in the Geometry cannot be selected. In order to delete objects from the Geometry, you must 
choose Geometry>Erase geometry>Object or Geometry>Erase geometry>Complete.

The objects in the Geometry can be identified. All intersections of objects in the geometry can be 
captured.



Marks
Marks are small symbols which are used to mark positions, e.g. during construction. They can be defined 
during construction and are shown as small squares with a cross through them. They are only visible on 
screen and can not be printed or copied to the clipboard.

Marks can be made in various ways. They can be placed directly on to the screen with the cursor, or they 
can be constructed with commands from the Geometry>Division sub-menu.

In addition, marks are used in conjunction with the command Geometry>Multiple copy>Markings. 
Using this command, it is possible to copy selected objects to several marked places in the drawing at the 
same time.



Fonts
TommySoftware® CAD/DRAW Professional uses its own fonts both on screen and for printed output. 
Only in exceptional cases are the Windows system fonts used.

Various vector fonts are included for this purpose, amongst others the fonts DINDRAFT and DINLQ. 
These are vector fonts which are particularly suitable for annotating technical drawings and for depicting 
measurements. DINDRAFT consists only of lines and is therefore highly suitable for output on plotters. 
The other fonts generally consist of filled areas and are therefore less suitable for plotters.

By using the commands Special>Single line text and Special>Multiple line text it is possible to place 
text on the screen. In the dialog boxes which appear when you choose one of these commands you can 
choose which of the available fonts is to be used from a combo box. To edit text after it has been placed in
a drawing, first select it and then choose Special>Edit text.

The typeface used to show measurements is set from a combo box in the dialog box which appears when 
you choose Measure>Dimension>Parameters.

Fonts are administered with the command Special>Font table.

In order to display a font, it must first be loaded by choosing the command Special>Load font or by 
setting it to load automatically on start up with the command System>Settings>Autoload.



Symbols and Blocks
Inserting symbols into TommySoftware® CAD/DRAW Professional uses a system of external references. 
This means that whenever a symbol is inserted into a drawing, a reference marker is inserted which tells 
the program to insert a certain symbol from a certain library at that point rather than a copy of that 
symbol. which means that the symbol remains identifiable.

Naturally, the symbols imported into a drawing can, for example, be rotated, scaled or manipulated in 
similar ways. A special matrix saved with the imported drawing makes this possible. The original symbol 
in the library is not altered.

This saves significant amounts of memory because, regardless of the actual size of the symbol, only a 
reference to the symbol is ever saved. It is very easy to place a symbol from an updated library into a 
drawing. The updated library is simply copied on top of the old one. When the drawing is redrawn or 
printed, the updated symbol will be used automatically, because the references will have remained the 
same.

Apart from this, symbols can have attributes applied to them (e.g. article number, description, price); see 
also Library>Edit Attributes. These attributes can be used to generate a parts list; see 
Library>Generate parts list.

The command Library>Insert Symbol/Block can be used to insert symbols from a library into a 
drawing. Using Library>Read Symbol/Block you can convert objects from a drawing to symbols and 
store them in a library.

Functionally, blocks and symbols are identical. The difference is that blocks are not stored in external 
libraries, but each block's definition is stored in the drawing. This means that after a block has been read 
in using the command Library>Read Symbol/Block the block definition will be saved with the drawing.
If a block is inserted, a reference to this definition, the so-called Instance, will be placed into the drawing.

It is possible to convert blocks to symbols or vice versa using the commands 
Library>Transform>Symbols to blocks or Library>Transform>Blocks to symbols.

Symbol and block definitions can be nested, i.e. symbol or block definitions can contain references to 
other definitions. The maximum number or references which can be nested is ten.

If you want to work on part of a symbol, you can convert symbols or blocks to their constituent objects 
with the commands Library>Resolve symbol/block>Instance (single) and Library>Resolve 
symbol/block>Instance (multiple objects). If an instance refers to a definition which again contains 
instances, these instances remain after the first deletion. In order to remove these instances, use the 
command Library>Resolve symbol/block. This process has to be repeated until all the instances have 
been removed.

In order to be able to insert a symbol from a library into a drawing, the library has to be loaded. To do 
this, either choose Library>Load library or by making the library load automatically when the program 
starts. See System>Settings>Autoload.



Measure
These commands can be use to attach dimensions to drawing elements. They can be generated in many 
different ways, using a multitude of settings which affect the appearance and behavior of the dimension.
These commands lead to a dialog box in which the appearance of the dimension figures, the dimension 
line and possibly the extension lines can be set. Some commands (e.g. Measure>Dimension>Line, 
point), which produce dimension lines give rise to the following dialog box:

Starting Point
These settings influence the appearance of the terminator at the starting point of the dimension line.
The radio buttons with depictions of various terminators allow you to choose the type of terminator.

Orientation
The orientation of the terminator can be chosen from this drop-down list.
If the orientation is Rotated, the terminator will be rotated by 180° and the dimension line will be 
drawn elongated., i.e. it will extend beyond the starting point.
If the orientation is Automatic the terminator will be rotated by 180° if the length of the 
dimension line is shorter than 30 × its width.
Extension line
If this check box is enabled, an extension line will be drawn from the starting point of the 
dimension line..

Ending Point
These settings influence the appearance of the terminator at the ending point of the dimension line.
The radio buttons with depictions of various terminators allow you to choose the type of terminator.

Orientation
The orientation of the terminator can be chosen from this drop-down list.
If the orientation is Rotated, the terminator will be rotated by 180° and the dimension line will be 
drawn elongated., i.e. it will extend beyond the starting point.
If the orientation is Automatic the terminator will be rotated by 180° if the length of the 
dimension line is shorter than 30 × its width.
Extension line
If this check box is enabled, an extension line will be drawn from the starting point of the 
dimension line..

Dimension
These settings influence the appearance and position of the dimension, that is the dimension itself as 
well as the associated text and tolerances.

Font
Choose the font in which the dimension should be shown from this list.
Dimension
Enter the height of the dimension text in this field. Values between 3.5 and 7.0 mm are 
recommended.
Tolerance
Enter the height of the text used for tolerances in this field. Values between 2.5 and 5.0 mm are 
recommended. The size should be one step (factor 1.41) smaller than the main dimension text.
Accuracy
Specifies the number of decimal places when numbers are displayed as numbers and decimals.
Specifies the maximum power to be used when numbers are displayed as exponentials.
In both cases values from 0 to 9 are allowed.
Coordinate system



Choose the coordinate system which will apply to the dimension line from this list. This system 
determines the scale, units, text font etc.
The accuracy will however be taken from the previously entered field.
Adapt dimension
If this check box is enabled, the dimension will be automatically updated whenever the drawing is
altered.
Center dimension
If this check box is enabled, the dimension will be placed in the center of the dimension line. 
Additionally it can be positioned perpendicularly.
Dimension close
If this check box is enabled, the dimension will be automatically positioned close to the 
dimension line. It can also be positioned parallel to the dimension line.
Rotate dimension
If this check box is enabled, the dimension can be rotated by specifying a point. Otherwise the 
dimension is always displayed parallel to the dimension line.
Edit dimensions and tolerances
If this check box is enabled, a dialog box appears after the dimension has been entered in which 
the dimension text (including the dimension text itself) can be edited.
If the Adapt dimension check box is enabled, then the dimension will be overwritten when the 
next operation is carried out!

Dimension line
These settings influence the appearance and positioning of the dimension line and the extension lines.

Full length, perpendicular
If this check box is enabled, the dimension line will be shown at full length, i.e. with both 
terminators.
Extension lines will be perpendicular to the dimension line.
Full length, moved
If this check box is enabled, the dimension line will be shown at full length, i.e. with both 
terminators. Extension lines can run at a slope, determined by entering a point at the end of the 
dimension line.
Partial length, perpendicular
If this check box is enabled, only part of the dimension line will be shown. Points must be entered
to determine at which end of the dimension the terminator should be shown, and another point 
which determines the length of the dimension line.
Display dimension line
This check box must be enabled in order for dimension lines and extensions to be shown. 
Otherwise only the dimension line itself will be shown.
Enter dimens. direction
If this check box is enabled, a dimension direction different to the direction of the object whose 
dimensions are to be determined, can be entered. To do this, a point is entered which together 
with the starting point of the dimension, determines the dimension direction.
Distance by point
If this check box is enabled, the position of the dimension line is determined by entering a point 
through which it should run.
Fixed distance
If this check box is enabled, the dimension line will be positioned at the distance from the 
dimension which is shown in the field.
The point which has to be entered determines which side the dimension line should be shown on.
Multiple of distance
If this check box is enabled, the distance from the dimension will be determined by the value in 



the field; a multiple is also allowed so that the position of the point which has to be entered 
determines how often the    distance should be taken.

Some commands (e.g. Measure>Dimension>Coordinates) do not generate dimension lines: they bring 
up this dialog:

Font
Choose the font in which the dimension should be shown from this list.

Dimension
Enter the height of the dimension text in this field. Values between 3.5 and 7.0 mm are recommended.

Tolerance
Enter the height of the text used for tolerances in this field. Value between 2.5 and 5.0 mm are 
recommended. The size should be one step (factor 1.41) smaller than the main dimension text.

Accuracy
Specifies the number of decimal places when numbers are displayed as numbers and decimals. 
Specifies the maximum power to be used when numbers are displayed as exponentials. In both cases 
values from 0 to 9 are allowed.

System
From this list, choose the Coordinate System which should apply to the measurement. This system 
determines the scale, unit, appearance of numbers, etc.
The tolerance will however be taken from the Tolerance field, described above.

Adapt dimension
If this check box is enabled, the dimension will be automatically updated whenever the drawing is 
altered.

Center dimension
If this check box is enabled, the dimension will be placed in the center of the dimension line. It can 
also be positioned perpendicular to the dimension line.

Dimension close
If this check box is enabled, the dimension will automatically be placed close to the dimension line. 
Additionally, it can be positioned parallel to the dimension line.

Rotate dimension
If this check box is enabled, the dimension can be rotated by specifying a point. Otherwise the 
dimension is always displayed parallel to the dimension line.

Edit dimensions and tolerances
If this check box is enabled, a dialog box appears after the dimension has been entered in which the 
dimension text (including the dimension text itself) can be edited.
If the Adapt dimension check box is enabled, then the dimension will be overwritten when the next 
operation is carried out.

The Parameters set here are saved with each measurement object and can be altered afterwards with the 
command Measure>Dimension>Properties.
Some special commands, for example Measure>Dimension Line and Measure>Dimension can be used 
for altering specific properties of measurement objects.
Because text size and spacing are not altered by operations like scaling or distortion, the dimensions 
appear with the correct text size and spacing after such operations.
If the setting Adapt Dimension has not been enabled, the dimension can be updated with the command 
Measure>Dimension>Update.

If Edit Dimension and Tolerances has been enabled, the dialog box described under Measure>Edit 
dimension text appears automatically, where the dimension text (preceding text, measurements, 
following text, tolerances) can be edited.



These, and other, settings can be saved in settings files. See System>Settings>Save as.

After closing this dialog by clicking on OK, the relevant points for the current measurement object must 
be entered. The settings chosen in this dialog remain active until another (Measure) command is chosen. 
If you want to change the settings for the current measurement command, you must choose the command 
again, to set new parameters. The easiest way of doing this is by pressing SHIFT+ESC (see Key 
Assignments).

The following two examples illustrate procedure when measuring an object.

Measure>Dimension>Length, points
Using this command it is possible to measure a length whose endpoints are entered directly. This makes it
possible to measure random lengths which do not lie within one or more object.

1. Enter the starting point
2. Enter the ending point

After entering the length, several points determining the position of the dimension and the dimension line 
must also be entered. The number of points which must be entered is dependent on the chosen 
measurement parameters.

If Display Dimension and Enter dimens. direction are enabled:
3. Enter the first dimension line definition point. This determines, relative to the starting point, the 

dimension direction.

If Display Dimension is enabled:
4. Enter the second dimension line definition point. This determines the separation of the dimension line

from the dimension. If Full Length, moved is enabled, this point also specifies the ending point of the 
dimension line.

If Display Dimension and Partial Length, perpendicular are enabled:
5. Enter the third dimension line definition point. This specifies the ending point of the dimension line.

If Center dimension or Dimension Close are not set:
6. Enter the first dimension definition point. This specifies the position of the dimension.

If Rotate dimension is enabled:
7. Enter the second dimension definition point. This specifies, relative to the dimension position, the 

direction in which the dimension should be rotated.

Measure>Dimension>Length, object
This command can be used to measure a length specified by identifying an object edge. This makes it 
easy to measure lengths within existing objects without having to enter the points individually.



Generate Surface
The Special>Generate surface command allows you to generate a surface area from several overlapping 
or adjacent objects. Only geometric objects, e.g. lines, circles, ellipses or curves are used. Other objects 
such as text or measurement lines are ignored.

Because the outline of an object can only consist of lines and arcs, all objects are converted during 
processing. Objects which contain other elements e.g. ellipses, are converted into line sections. The 
precision of the conversion is set with the command System>Settings>Screen.

Generation is virtually automatic, but all objects which are relevant to the area being generated must be 
selected. The easiest way to do this is using the command Selection>Select section>Overlapping. You 
should select only the minimum number of objects necessary because the number of objects influences 
the time needed for calculation. After this a reference point, which defines the surface to be generated is 
entered

The position of the reference point determines which surface is generated. The generation routine's 
strategy can be described as follows:

Find the element from the selected group of objects which is nearest to the reference point;
Starting with this element, find a closed outline which encloses the reference point and is as short as 
possible;
If there is no such outline, find the largest possible closed outline around all the selected objects;
If this is not possible either, display an information message.

The position of the reference point has the following effects: If the reference point is within one or more 
closed surfaces, the smallest of them will be generated. If it is outside, the largest possible surface 
surrounding all the objects will be generated. The graphic below illustrates this.

In the case of a clearly differentiated surface (which is usually the case) you can simply click in the 



middle of the surface.
You should never click on or near a line or arc whose end is not connected to another element, because in 
this case the generation process will not be able to find a closed outline connected with that object.

The tolerance set with the command Special>Generate area Parameters specifies how close two objects
have to be to each other in order to affect each other. If the tolerance is set to a very low value, some 
tangents of lines and circles will no longer be recognised properly by the Generate Surface function.

After entering the reference point, the surface generation begins. If a surface is found, it is inserted and 
selected; the previously selected objects are deselected. This means that the newly generated surface can 
be worked with straight away; for example it can be hatched (see Hatching).

The surface will be generated using the properties set with the command Special>Generate 
surface>Properties.

Note: System memory is used during the surface generation process. With complex surfaces there may 
not be enough system memory. If the memory requirement cannot be reduced by deselecting unnecessary 
objects, available system memory must be increased using the command System>Settings>Memory.



Hatching
These commands are used to shade objects. It is possible to define two groups of objects which can be 
joined in three ways.

The first group of objects consists of all objects selected in main selection mode. The second group of 
objects consists of all objects selected in secondary selection mode. The current selection mode can be 
changed from the Selection menu or by clicking on a button in the Panel.
Objects which do not enclose an area, for example lines, are ignored during hatching. If an area whose 
outline is made up from individual objects is to be hatched, then this area must first be transformed into a 
surface using the command Special>Generate surface (Generate Surface).
Surfaces with overlapping outlines are always treated correctly.

The hatching type which has been set using the command Measure>Hatching type will be used. In 
addition the properties set with Measure>Hatching properties>Objects will be respected.

During hatching, one or more hatching objects will be generated. These can be broken into individual 
lines with the command Transform>Resolve objects to lines.

Union
This command hatches the union of both groups of objects, i.e. all areas covered by at least one object are
hatched. For this kind of hatching it is sufficient simply to select those objects (using the Main selection 
mode)which should be hatched, as no distinction has to be made between different objects.

Intersection
This command hatches the intersection of object groups, i.e. all areas covered by at least one object from 
the first group and also covered by at least one object from the second group will be hatched.
This command is used for example when the overlapping area of    two circles is to be hatched. In this 
case each circle must belong to a different group.

Difference
This command hatches the difference between two object groups, i.e. all areas which are covered by only 
one of the object groups are hatched.
This command is mainly used when hatching an area which surrounds a smaller area which is not to be 
hatched. The smaller area must belong to the second group.




